newby questions

Mickael Remond <>
Mon Nov 29 09:19:30 CET 2004


Matthias Lang wrote:
> Pat29 writes:
> 
>  > Sorry for these questions but i had been learning Erlang (2 weeks) 
>  > with the french book and i got the following error after launched 
>  > this command on WinXP SP2
> 
>  > D:\Pat29\erlang\Erlang Book\ch8\ex1\src>erl -sname database -pa ebin
>  > 
>  > {error_logger,{{2004,11,28},{14,47,58}},'Protocol: ~p: register/listen 
>  > error: ~p ~n',[inet_tcp,enotsock]}
> 
> [...]
> 
>  > {{badmatch,{error,enotsock}},[{gstk_port_handler,init,2}]}
> 
> It's saying that it tried to open a TCP socket and the operating
> system replied 'no way, José'. If this was happening on a unix
> machine, I'd say "have you compiled a kernel without sockets or
> without IP networking?", but since it's windows I'm clueless.
> 
> I'm guessing that if you start non-distributed Erlang (i.e. just run
> 'erl') and then do this:
> 
>    1> gen_tcp:listen(0, []).
>    {ok,#Port<0.82>}
> 
> your setup will reply {error, enotsock} instead of {ok, Port}. Right?
> 
> Can you do anything else with TCP on that machine, for instance does
> 'telnet' work? 

I have already been encountering some strange problem with Erlang on 
Windows XP when testing the Erlang REPOS CDROM 
(http://www.erlang-projects.org/Public/projects/workgroups/repos/erlang_repos_1.0/view). 
On some Windows XP computers, we encountered the same symptom (unable to 
open a socket). On other Windows XP computers the REPOS CDROM is working.
Networking, for example with telnet, was working properly on the 
computer. We tried to play with the Firewall setting without any luck.

Does someone now if the socket API has changed in Windows XP ?

-- 
Mickaël Rémond
  http://www.erlang-projects.org/



More information about the erlang-questions mailing list