64 bit Erlang on Opterons?

Peter-Henry Mander <>
Thu Jul 29 18:35:37 CEST 2004


... and you all may call me a fool! I should have RTFM.

The notes.html file specifically states that erl_interface _is_ 64 bit capable. Duh!

I was using version erl_interface-3.4.5 instead of erl_interface-3.4.4
and all works now. What happened with erl_interface-3.4.5? It wasn't
happy at all!

Pete.


On Thu, 29 Jul 2004 17:01:34 +0100
Peter-Henry Mander <> wrote:

> 
> Hi Kostis,
> 
> This is probably a problem with erl_interface, and nothing to do with AMD64 HiPE, so apologies in advance.
> 
> I'm getting the following errors.
> 
> EIO on erl_connect in the C-node
> 
> =ERROR REPORT==== 29-Jul-2004::17:54:26 ===
> ** '': Connection attempt from node '' rejected since it cannot handle extended pids and ports. **
> 
> The "extended pids and ports" tells me that the erl_interface library is probably not made for 64 bit systems.
> 
> Is erl_interface the culprit? If so, how do I fix erl_interface?
> 
> Pete.
> 
> 
> -- 
> "The Tao of Programming
>  flows far away 
>  and returns 
>  on the wind of morning."
> 


-- 
"The Tao of Programming
 flows far away 
 and returns 
 on the wind of morning."




More information about the erlang-questions mailing list