kill "if" and "case" instead! [was Re: Enhanced type guard syntax]

Vance Shipley <>
Fri Sep 19 09:53:48 CEST 2003


}  Not mentioning that the resulting function names can be well chosen too.

I get stuck thinking about what to name things.  foo2, foo3, foo4 are 
easy enough but anything else leaves me idle pondering how a name should 
be chosen.  I like to use funs because I don't need to name them or if I 
do I can call them F or Fun. 

	-Vance

On Fri, Sep 19, 2003 at 07:57:29AM +0100, Peter-Henry Mander wrote:
}  
}  In this case, may I propose that "if" and "case" were stuffed into the 
}  blender? They're _not_ orthogonal to other features!
}  
}  I cannot find any solid argument toward keeping and using them when 
}  writing equivalent code using functions alone makes (at least my) code 
}  much less prone to the Dreaded Indent pushing against the right margin. 
}  Not mentioning that the resulting function names can be well chosen too.



More information about the erlang-questions mailing list