Very strange behaviour!

Chris Pressey cpressey@REDACTED
Wed May 21 03:19:02 CEST 2003

On Tue, 20 May 2003 08:24:55 +0200
"Vlad Dumitrescu" <vlad_dumitrescu@REDACTED> wrote:

> Oh, and it seems like it's the same at work... very strange! 
> It is also on Windows (XP and 2000), where it worked before. I think
> it's about a week since I tried last time. And now, it just hangs and
> does nothing...
> Any ideas about what the problem might be?

Well - um - not really, but maybe.

More info might help (R9B-1? -name, -sname, or no distribution?)

I've encountered a similar thing occasionally on Windows 95 when trying
to start werl after closing it (usually after having started and closed
it several times.)

The problem in my case seemed to be that epmd didn't always stop when
werl stopped, and when werl was started again, it was waiting for its
new instance of epmd (which wasn't starting because the old instance of
epmd was still running.)  At least, this is as far as I can gather.  My
solution was to Ctrl+Alt+Del and kill epmd before starting werl again.

So basically I suspect werl is waiting for something - might be epmd, or
if you're using -name distribution, it might be a DNS problem, or
something.  Sorry, that's the best I can come up with :)

> regards,
> Vlad

HTH (in some small way)

More information about the erlang-questions mailing list