gs on MacOS X in R9B-0

Kent Boortz <>
Tue Oct 22 19:48:55 CEST 2002


Sean Hinde <> writes:
> > Does this work ?
> > If it does how does one go about to make it work ?
> > The MacOS X tcl/tk version (at 
> > http://sourceforge.net/projects/tcl) does 
> > appear to differ in build / install process compared to linux/unix so 
> > I'm not all that sure how much help the README file in 
> > otp_src_R9B-0/lib/gs/tcl is.
> > I tried to rename MacOSXTk8.4a4.tar.gz (the precompiled mac 
> > version) and 
> > put it at:
> > otp_src_R9B-0/lib/gs/tcl/binaries/powerpc_darwin6.tar.gz as 
> > ./configure 
> > appears to assume, this works as far as allowing OTP to 
> > compile without 
> > error as as well as putting  some stuff in 
> > otp_src_R9B-0/lib/gs/priv/Applications (wish) and  
> > otp_src_R9B-0/lib/gs/priv/Library (tcl and tk frameworks). I 
> > would guess 
> > that part of the problem is that the paths to the tcl/tk stuff isn't 
> > quite where a unix system would expect them.
> 
> I had a go by making a link from /Applications/Wish
> Shell.app/Contents/Macos/Wish Shell  to a more sane /usr/local/wish and gs
> did pick up the wish executable and open up the little window you get when
> running Wish Shell.app normally. gs couldn't communicate with the wish shell
> though - I read something somewhere about problems with stdin/out.

The 8.4.0 Tcl/Tk distribution has a but in the MacOS X code that break
the usage of a pipe from Erlang to the wish program. I patched the
source and does work. The CVS version has a fix for the problem but I
haven't tried it yet.

There is not support in GS for "the MacOS X way" of finding the
executable yet so you need to create a link to athe wish executable as
Sean suggests,

kent



More information about the erlang-questions mailing list