Redhat 8.0

Kristoffer Andersson <>
Fri Oct 18 19:51:35 CEST 2002


Hi Martin!

Don't now if this is any help to you, but this is what I did to get R9 
to work on RH8.

The problem I had with building R9 or R8B-2 on RH8 was the 
Unicode(UTF-8) stuff, or at least I think that was the problem.
After reading the RH8 release notes more careful I tried to set the LANG 
variable to C when building OTP and it worked.

eg. <vanilla build>  
    prompt> ./configure
    prompt> env LANG=C make
    prompt> env LANG=C make install

I'm not sure that this is a good soloution (or a soloution at all) for 
the "RH8 problem", but so far it worked for me.

Regards,
/Toffe

martin j logan wrote:

>Hello, I was wondering if anyone knows if there will be a patch for R9
>to make it compatible with Redhat Linux 8.0. I have tried to get it
>going myself but it seems as though the matter is not entirely trivial.
>I have included the last error that I got in case anyone has seen the
>same thing. The observed errors seem to be similar to the those seen
>when trying to build R8-2 on the same OS. The error below may be my own
>as it is comes after a few of my own "fixes". I think that my "fixes"
>were non-destructive though. Thanks in advance for any help.
>
>Cheers,
>Martin
>
>Below is the text from the gmake/make same for both.
>
>erlc -W  -bbeam  +debug_info  -o../ebin
>hipe_x86_ra_ls_postconditions.erl
>erlc -W  -bbeam  +debug_info  -o../ebin
>hipe_x86_ra_measure_live_regs.erl
>erlc -W  -bbeam  +debug_info  -o../ebin hipe_x86_ra_postconditions.erl
>erlc -W  -bbeam  +debug_info  -o../ebin hipe_x86_registers.erl
>make[3]: Leaving directory `/usr/local/src/otp_src_R9B-0/lib/hipe/x86'
>make[3]: Entering directory
>`/usr/local/src/otp_src_R9B-0/lib/hipe/tools'
>erlc -W  -bbeam  +debug_info  -o../ebin hipe_tool.erl
>erlc -W  -bbeam  +debug_info  -o../ebin hipe_profile.erl
>erlc -W  -bbeam  +debug_info  -o../ebin hipe_ceach.erl
>erlc -W  -bbeam  +debug_info  -o../ebin hipe_timer.erl
>erlc -W  -bbeam  +debug_info  -o../ebin hipe_jit.erl
>make[3]: Leaving directory `/usr/local/src/otp_src_R9B-0/lib/hipe/tools'
>=== Leaving application hipe
>make[2]: Leaving directory `/usr/local/src/otp_src_R9B-0/lib/hipe'
>make[1]: Leaving directory `/usr/local/src/otp_src_R9B-0/lib'
>if test ! -d bootstrap/lib/kernel ; then mkdir bootstrap/lib/kernel ; fi
>if test ! -d bootstrap/lib/kernel/ebin ; then mkdir
>bootstrap/lib/kernel/ebin ;
>fi
>if test ! -d bootstrap/lib/kernel/include ; then mkdir
>bootstrap/lib/kernel/include ; fi
>cp lib/kernel/ebin/*.beam bootstrap/lib/kernel/ebin
>cp lib/kernel/include/*.hrl bootstrap/lib/kernel/include
>if test ! -d bootstrap/lib/hipe ; then mkdir bootstrap/lib/hipe ; fi
>if test ! -d bootstrap/lib/hipe/ebin ; then mkdir
>bootstrap/lib/hipe/ebin ; fi
>if test -f lib/hipe/ebin/hipe.beam ; then cp lib/hipe/ebin/*.beam
>bootstrap/lib/hipe/ebin; fi
>if test ! -d bootstrap/lib/parsetools ; then mkdir
>bootstrap/lib/parsetools ; fiif test ! -d bootstrap/lib/parsetools/ebin
>; then mkdir bootstrap/lib/parsetools/ebin ; fi
>if test ! -d bootstrap/lib/parsetools/include ; then mkdir
>bootstrap/lib/parsetools/include ; fi
>cp lib/parsetools/ebin/*.beam bootstrap/lib/parsetools/ebin
>cp lib/parsetools/include/*.hrl bootstrap/lib/parsetools/include
>if test ! -d bootstrap/lib/asn1 ; then mkdir bootstrap/lib/asn1 ; fi
>if test ! -d bootstrap/lib/asn1/ebin ; then mkdir
>bootstrap/lib/asn1/ebin ; fi
>cp lib/asn1/ebin/*.beam bootstrap/lib/asn1/ebin
>cd lib && \
>  ERL_TOP=/usr/local/src/otp_src_R9B-0
>PATH=/usr/local/src/otp_src_R9B-0/bootstrap/bin:${PATH} \
>        make opt TERTIARY_BOOTSTRAP=true
>make[1]: Entering directory `/usr/local/src/otp_src_R9B-0/lib'
>=== Skipping subdir snmp_dummy, it is missing
>make[2]: Entering directory `/usr/local/src/otp_src_R9B-0/lib/snmp'
>=== Entering application snmp
>make[3]: Entering directory
>`/usr/local/src/otp_src_R9B-0/lib/snmp/mc_dummy'
>erlc -W  -o ../src ../src/snmp_mib_gram.yrl
>No function otp_ring0:start/2
>make[3]: *** [../src/snmp_mib_gram.erl] Aborted
>make[3]: Leaving directory
>`/usr/local/src/otp_src_R9B-0/lib/snmp/mc_dummy'
>make[3]: Entering directory `/usr/local/src/otp_src_R9B-0/lib/snmp/mibs'
>erlc -W  -pa /usr/local/src/otp_src_R9B-0/lib/snmp/ebin -I
>/usr/local/src/otp_src_R9B-0/lib/snmp/priv/mibs  -o ../priv/mibs
>RFC1213-MIB.mib
>No function otp_ring0:start/2
>make[3]: *** [../priv/mibs/RFC1213-MIB.bin] Aborted
>make[3]: Leaving directory `/usr/local/src/otp_src_R9B-0/lib/snmp/mibs'
>make[3]: Entering directory `/usr/local/src/otp_src_R9B-0/lib/snmp/src'
>erlc -W  -bbeam  +debug_info -I../include
>+'{parse_transform,sys_pre_attributes}'
>+'{attribute,insert,app_vsn,"snmp-3.3.8"}'
>-I/usr/local/src/otp_src_R9B-0/lib/stdlib -Ddefault_verbosity=silence
>-o../ebin snmp_acm.erl
>./snmp_acm.erl:26: can't find include file "STANDARD-MIB.hrl"
>./snmp_acm.erl:27: can't find include file "SNMP-FRAMEWORK-MIB.hrl"
>./snmp_acm.erl:28: can't find include file "SNMPv2-TM.hrl"
>./snmp_acm.erl:125: undefined macro 'snmpUDPDomain'
>./snmp_acm.erl:186: undefined macro 'snmpEnableAuthenTraps_instance'
>./snmp_acm.erl:94: function handle_authentication_failure/0 undefined
>./snmp_acm.erl:88: function init_ca/2 undefined
>make[3]: *** [../ebin/snmp_acm.beam] Error 1
>make[3]: Leaving directory `/usr/local/src/otp_src_R9B-0/lib/snmp/src'
>make[3]: Entering directory
>`/usr/local/src/otp_src_R9B-0/lib/snmp/examples'
>make[3]: Nothing to be done for `opt'.
>make[3]: Leaving directory
>`/usr/local/src/otp_src_R9B-0/lib/snmp/examples'
>make[3]: Entering directory
>`/usr/local/src/otp_src_R9B-0/lib/snmp/priv/conf'
>make[3]: Nothing to be done for `opt'.
>make[3]: Leaving directory
>`/usr/local/src/otp_src_R9B-0/lib/snmp/priv/conf'
>=== Skipping subdir doc/src, it is missing
>=== Leaving application snmp
>make[2]: Leaving directory `/usr/local/src/otp_src_R9B-0/lib/snmp'
>make[1]: Leaving directory `/usr/local/src/otp_src_R9B-0/lib'
>if test ! -d bootstrap/lib/snmp ; then mkdir bootstrap/lib/snmp ; fi
>if test ! -d bootstrap/lib/snmp/ebin ; then mkdir
>bootstrap/lib/snmp/ebin ; fi
>if test ! -d bootstrap/lib/snmp/include ; then mkdir
>bootstrap/lib/snmp/include
>; fi
>cp lib/snmp/ebin/*.beam bootstrap/lib/snmp/ebin
>cp: cannot stat `lib/snmp/ebin/*.beam': No such file or directory
>gmake: *** [tertiary_bootstrap_copy] Error 1 
>
>
>
>  
>




More information about the erlang-questions mailing list