undocumented modules in OTP
Wed Aug 14 13:17:34 CEST 2002
> Richard Carlsson <richardc@REDACTED> writes:
> > It was highly unofficial in R8. For R9, we have renamed it to the
> > shorter "proplists"
> I've complained about this before, but anyway here it goes again...
> Wouldn't it be nice if this kind of module was named consistently? We
> now have, on one hand:
> dict, digraph, ets, dets, orddict, queue, string, sofs.
> On the other:
> sets, ordsets, lists, gb_sets, gb_trees, proplists.
> IMNSHO, the plural "s" in the latter group is ugly and should go away
> as soon as possible.
Well I will agree that being consistent is very nice. But this should
have been thought of a long time ago, alas it was not. Changing it now
is just going to cause much more trouble than it is worth. Think of the
millions of lines of code that would have to be changed. You could have
a solution where you have a wrapper moudule lists for list but how
ugly would not that be ... so you will just have to live with it.
Ericsson AB - OTP team
More information about the erlang-questions