inappropriate Mach-O under MacOS X

david wallin <>
Wed Sep 5 21:36:52 CEST 2001


I'm trying to load a small driver that I wrote but I can't get it 
working. I'm running R7B-3 under MacOS X and I keep getting this error 
message :

{error,{open_error,"dyld: inappropriate Mach-O file"}}

What should I do to resolve this ? I have tried various flags to the 
compiler/linker but nothing seems to do the trick.


More information about the erlang-questions mailing list