Problems compiling R7-B on Debian Linux

Rudolph van Graan <>
Wed Aug 8 13:19:57 CEST 2001


Hi all,

Yesterday, I've tried to compile R7-B on Debian Linux (v2.2) on i386.
The ./configure worked well, giving no significant output. 

However, running make produced the following output:

einstein:/usr/local/otp_src_R7B-2# make
cd erts && ERL_TOP=/usr/local/otp_src_R7B-2 make NO_START_SCRIPTS=true
opt
make[1]: Entering directory `/usr/local/otp_src_R7B-2/erts'
make[2]: Entering directory `/usr/local/otp_src_R7B-2/erts/emulator'
make -f i686-pc-linux-gnu/Makefile TYPE=opt
make[3]: Entering directory `/usr/local/otp_src_R7B-2/erts/emulator'
make[3]: i686-pc-linux-gnu/Makefile: No such file or directory
make[3]: *** No rule to make target `i686-pc-linux-gnu/Makefile'.  Stop.
make[3]: Leaving directory `/usr/local/otp_src_R7B-2/erts/emulator'
make[2]: *** [opt] Error 2
make[2]: Leaving directory `/usr/local/otp_src_R7B-2/erts/emulator'

<snip>

Repeated for 
	`/usr/local/otp_src_R7B-2/erts/etc/common'
and
	`/usr/local/otp_src_R7B-2/erts/epmd'

I guess it is simply a problem with Makefile, but before I try to figure
out what is wrong - has anyone got an idea for a quick fix here?

For information:

I downloaded otp_src_R7B-2.tar.gz, 
done a tar xvzf otp_src_R7B-2.tar.gz in /usr/local/
that produced /usr/local/otp_src_R7B-2/
cd /usr/local/otp_src_R7B-2/
make clean
./configure
make..

Regards,

Rudolph



More information about the erlang-questions mailing list