variable naming conventions

Simon Bennett <>
Thu Nov 9 15:07:55 CET 2000


> It took me a while to understand what the heck was the meaning with
> the variable "Gat". Finally, I realized that it was "Tag" backwards,
> since check_tag_list/3 is called with lists:reverse(Tag).

Now should it be

Tag[2] = lists:reverse(Tag[1]),
check_tag_list(TagList, [], Tag[2]).

or

Gat[2] = lists:reverse(Tag[1]),
check_tag_list(TagList, [], Gat[2]).

or 

[2]gaT = lists:reverse(Tag[1]),
check_tag_list(TagList, [], [2]gaT).

:-)

Simon



More information about the erlang-questions mailing list