net_adm:ping/1 in Linux

Nuno Silva <>
Fri Nov 19 14:38:47 CET 1999


Hi,

 

I would like to add some information to my previous post, concerning the problems with net_adm:ping/1

There were a few replies to my post, suggesting that the to hosts were network unreacheble, but that is not true since I tested with the OS ping using both names (DNS) and IP address and it works fine. The cookie term is set to 'nocookie' in all the hosts.

Then, I tried something new: I kiledl epmd deamon in the Linux host, and run it again with debug option set (epmd -d &). Once done, I run net_adm:ping/1 to the linux host with epmd running in debug mode. The result is the same (pang), but the epmd deamon reported:
***** Fri Nov 19 13:25:24 1999: opening connection on file descriptor 5

***** Fri Nov 19 13:25:24 1999: ** Sent PORT2_RESP (ok)

***** Fri Nov 19 13:25:24 1999: closing connection on file descriptor 5     

wich means (once again) that hosts are mutualy reacheble.

I made the same experience (kill and recreate epmd) in two Windows hosts, the result of course is 'pong', but the epmd report is the same as above.
I made the same experience in two Linux hosts the result is 'pong' and the epmd is the same.

Any ideas?...

Nuno Silva
____________________________________________
Nuno Silva
DEI - ISEP - IPP (Polytecnic Institut of Porto)
Rua Dr. António Bernardino de Almeida
4200 - 072 Porto
PORTUGAL

Tel.: + 351 228340500
Fax: +351 228321159
mailto:
http://www.dei.isep.ipp.pt/~nsilva
-------------- next part --------------
An embedded message was scrubbed...
From: Nuno Silva <>
Subject: Contacting with net_adm:ping/1
Date: Thu, 18 Nov 1999 15:40:21 -0000
Size: 1750
URL: <http://erlang.org/pipermail/erlang-questions/attachments/19991119/01312a22/attachment.mht>


More information about the erlang-questions mailing list