[erlang-patches] Fix erlang:now/0 to be bigger_than_last_time/0

Fred Hebert <>
Tue Apr 1 13:26:26 CEST 2014

Why I agree:

- Backwards compatibility and proper deprecation is annoying, not a
  convenience. It is far more confusing to have a function relating to
  time named 'now' than having breaking changes in your code, no matter
  how well-documented it is.
- The name you chose is less descriptive than before (it no longer
  relates to time), which forces people to look inside docs, which is
  great. I love documentation.
- You orphaned a bunch of names in other modules, namely:
   - timer:now_diff/2
   - calendar:now_to_local_time/1
   - calendar:now_to_universal_time/1
   - calendar:now_to_datetime/1
  Which logically now need to be renamed:
   - timer:bigger_than_last_time_diff/1
   - calendar:bigger_than_last_time_to_local_time/1
   - calendar:bigger_than_last_time_to_universal_time/1
   - calendar:bigger_than_last_time_to_datetime/1
  I always felt calendar had way too short names and believe this is an
  improvement for the better in the long term.
- Today is the best day for this change to happen, definitely.


On 04/01, JD Bothma wrote:
> This patch tries to improve the name of erlang:now/0 to make its behaviour
> a little more obvious for the sake of least surprise. It's a breaking
> change, but I really think it's worth it to reduce confusion.
> This is only the first step - if you think it looks ok I can do the rest.
>     git fetch git://github.com/jbothma/otp.git fix-erlang-now-name
> https://github.com/jbothma/otp/compare/erlang:maint...fix-erlang-now-name
> https://github.com/jbothma/otp/compare/erlang:maint...fix-erlang-now-name.patch
> All the best
> JD

> _______________________________________________
> erlang-patches mailing list
> http://erlang.org/mailman/listinfo/erlang-patches

More information about the erlang-patches mailing list