[erlang-patches] [erlang-bugs] R16A: Small inconvenience with Unicode strings in the shell

Anthony Ramine <>
Sat Feb 9 14:01:47 CET 2013


Hi,

I've got a fix:

	git fetch https://github.com/nox/otp.git wide-chars

	https://github.com/nox/otp/compare/erlang:master...wide-chars
	https://github.com/nox/otp/compare/erlang:master...wide-chars.patch

I can't test the win32 part though.

Björn, should I add some autoconf machinery to know whether wcwidth() is
available?

Regards,

-- 
Anthony Ramine

Le 30 janv. 2013 à 21:48, Loïc Hoguin a écrit :

> Erlang R16A (erts-5.10) [source] [64-bit] [smp:4:4] [async-threads:10] [hipe] [kernel-poll:false]
> 
> Eshell V5.10  (abort with ^G)
> 1> "aaa".
> "aaa"
> 2> "日本".
> "日本"
> 3>3>3>3>3>3>3>3>3>3>3>3>3>3>3>3>3>3>
> 
> In 1> I wrote an ASCII string, got the result, then tried to up-down-up-down-up-down-up-down and it adds/remove "aaa" as intended.
> 
> Then in 2> I wrote an Unicode string, got the result (nice!), then tried to do the same up-down mimic except everytime I did down when the Unicode text was printed, it added a 3> on the line. It only does so for the Unicode and not for ASCII.
> 
> Thinking there's some missing cleanup there.
> 
> -- 
> Loïc Hoguin
> Erlang Cowboy
> Nine Nines
> http://ninenines.eu
> _______________________________________________
> erlang-bugs mailing list
> 
> http://erlang.org/mailman/listinfo/erlang-bugs



More information about the erlang-patches mailing list