[erlang-bugs] SSL socket gets closed abruptly

Loïc Hoguin <>
Fri Feb 7 16:32:12 CET 2014


On 02/06/2014 05:46 PM, Loïc Hoguin wrote:
> On 02/06/2014 05:34 PM, Loïc Hoguin wrote:
>> Since my issue magically fixed itself I can continue with my work, at
>> least.
>
> Scratch that, I forgot that I attempted to reduce the size being sent
> (2MB instead of 19MB) and sending less "fixed it". So I'm back to being
> able to reproduce. I will attempt to bisect tomorrow.
>
> Note that when I tried doing a simpler example in its own module I
> wasn't able to reproduce it, so I'm pretty much stuck with trying the
> test suite until I find the faulty commit, and won't be able to give
> much more than that.

Bisect leads me to 
https://github.com/erlang/otp/commit/5cd05af9b0ed994cf44bbd8ad7c5ee3119f952ff

Yeah I got nothing.

Ingela can you try fetching Cowboy and running the test suite (make 
tests) and then look at the ct logs to see if you also got the issue? 
the multipart_large tests should fail with SSL.

I really don't have a clue on where to go from here. I am not even sure 
the commit is relevant.

Have a nice week-end!

-- 
Loïc Hoguin
http://ninenines.eu


More information about the erlang-bugs mailing list