[erlang-bugs] SSL sslv3 not working as expected?

Ingela Anderton Andin <>
Thu Feb 6 21:29:50 CET 2014


Hi!

On 02/06/2014 05:59 PM, Loïc Hoguin wrote:
> Just [{cert, Cert}, {key, Key}, {port, 0}, {versions, [sslv3]}] does it.

You mean that you get it when you input certs as binaries? Could it be 
related to https://github.com/erlang/otp/pull/163
We  want to include this pull request but it solves two problems and 
only one persists and we are waiting for the pull
request to be updated.


Regards Ingela Erlang/OTP team - Ericsson AB


>
> The certificate and key are generated using the module from the SSL 
> test suite for generating test certificates.
>
> I have not tried to run the SSL test suite yet, I will take a look 
> tomorrow.
>
> On 02/06/2014 05:46 PM, Ingela Anderton Andin wrote:
>> Hi!
>>
>> In SSL V3 you are not supposed to get sha256!  Have you tried running
>> our test cases? We have a lot of test cases that run SSL-v3 that passes
>> in our environment. I suppose it could be an option handling bug somehow
>> as ssl have lots of options and we could have missed
>> some combination of options.
>>
>> Regards Ingela Erlang/OTP team - Ericsson AB
>>
>>
>> On 02/06/2014 05:33 PM, Anthony Ramine wrote:
>>> And judging from the spec, it shouldn’t handle it as only SHA1 and MD5
>>> can be used there.
>>>
>>
>> _______________________________________________
>> erlang-bugs mailing list
>> 
>> http://erlang.org/mailman/listinfo/erlang-bugs
>



More information about the erlang-bugs mailing list