[erlang-bugs] SSL sslv3 not working as expected?

Anthony Ramine <>
Thu Feb 6 17:19:14 CET 2014


The function ssl_v3:pad_1/1 and pad_2/1 don’t handle -define(SHA256, 4).

-- 
Anthony Ramine

Le 6 févr. 2014 à 17:08, Loïc Hoguin <> a écrit :

> Hello,
> 
> While trying to debug a separate SSL issue I added {versions, [sslv3]} to the listen call of the Cowboy test suite. This made everything break with huge error reports and the following stack trace:
> 
> ** Reason for termination =
> ** {{case_clause,{4}},
>    [{ssl_v3,mac_hash,3,[{file,"ssl_v3.erl"},{line,163}]},
>     {tls_record,encode_plain_text,4,[{file,"tls_record.erl"},{line,134}]},
>     {tls_connection,encode_handshake,4,
>                     [{file,"tls_connection.erl"},{line,362}]},
>     {tls_connection,send_handshake,2,
>                     [{file,"tls_connection.erl"},{line,108}]},
>     {ssl_connection,client_certify_and_key_exchange,2,
>                     [{file,"ssl_connection.erl"},{line,1038}]},
> {tls_connection,next_state,4,[{file,"tls_connection.erl"},{line,458}]},
>     {gen_fsm,handle_msg,7,[{file,"gen_fsm.erl"},{line,505}]},
>     {proc_lib,init_p_do_apply,3,[{file,"proc_lib.erl"},{line,239}]}]}
> 
> It pretty much does that for every test. I'm guessing this is not intended.
> 
> Does it with R16B02 and master from yesterday.
> 
> Enjoy,
> 
> -- 
> Loïc Hoguin
> http://ninenines.eu
> _______________________________________________
> erlang-bugs mailing list
> 
> http://erlang.org/mailman/listinfo/erlang-bugs



More information about the erlang-bugs mailing list