[erlang-bugs] GUI debugger Module view crashes in dual monitor setup

Peti Gömöri <>
Mon Jul 1 02:38:46 CEST 2013


Hi Mat,

debugger supports both the old gs and the new wx gui framework
By default it tries to start the wx version if wx is available otherwise
falls back to gs.
>From the error report I think you use the gs version.
As far as I know gs is not supported really by the OTP team any more.

Can you try to reproduce it with wx gui: debugger:start(global, default,
wx).

You might need to install wxWidgets in order for this to work.

br
Peter

On Sun, Jun 30, 2013 at 8:31 PM, Matthew Hegarty <>wrote:

>
> To reproduce
>
> 1.  debugger:start()
> 2.  Move Monitor window to secondary monitor (to LHS in my case)
> 3.  Module / Interpret  (choose module)
> 4.  Open Module View window
> 5.  It will crash as soon as there is a mouse move event with:
>
> Error in process <0.2844.0> with exit value:
> {badarith,[{dbg_ui_trace_win,handle_event,2,[{file,"dbg_ui_trace_win.erl"},{line,696}]},{dbg_ui_view,loop,1,[{file,"dbg_ui_view.erl"},{line,77}]}]}
>
> line is:
>
> dbg_ui_trace_win.erl
> 696     {coords, {gs:read(Win, x)+LastX-5, gs:read(Win, y)+LastY-5}};
>
> Workaround:  Open the module view window before moving it to secondary
> monitor, and then it won't crash.
>
> ===
>
> Erlang R16B (erts-5.10.1) [source] [64-bit] [smp:4:4] [async-threads:10]
> [kernel-poll:false]
>
> Linux Mint 64bit:  3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC
> 2012 x86_64 x86_64 x86_64 GNU/Linux
>
> 1st Monitor: Samsung 22" 1680 x 1050
> 2nd Monitor: Dell 19" 1290 x 1024
>
> _______________________________________________
> erlang-bugs mailing list
> 
> http://erlang.org/mailman/listinfo/erlang-bugs
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-bugs/attachments/20130701/31caa9e5/attachment.html>


More information about the erlang-bugs mailing list