[erlang-bugs] make docs fails in git master

Tuncer Ayaz <>
Tue Oct 2 18:04:13 CEST 2012


On Tue, Oct 2, 2012 at 5:59 PM, Patrik Nyblom
<> wrote:
> And you configure parameters are?

Nothing explicit, just automatic flags, with the fresh rebuild.
Not even --prefix. I'll mail you the configure.log files? Anything else?

> On Tue, 2 Oct 2012, Tuncer Ayaz wrote:
>
>> On Tue, Oct 2, 2012 at 5:14 PM,  <> wrote:
>>>
>>> OK,
>>>
>>> Also I've checked, the new erlang is in the PATH when running the,
>>> regardless of what you set before running make. So that's not the
>>> problem.
>>>
>>> I cannot in anyway reproduce this. So a few questions...
>>> What platform do you have?
>>> Can you run the command manually (emd2exml)?
>>> Is escript working for other scripts?
>>> Is the git directory clean?
>>> What are your configure parameters?
>>
>>
>> It works if I override the escript's emu_args:
>>
>> https://github.com/erlang/otp/blob/1a4e8f6e5c/make/emd2exml.in#L3
>> %%! -smp disable
>>
>> $ ERL_FLAGS="-smp enable" make docs
>>
>> HiPE is enabled automatically and "-smp disable" has - as far back as
>> I can remember - always provoked the following warning in the code
>> loader for each module loaded:
>> =INFO REPORT==== 2-Oct-2012::17:24:03 ===
>> <HiPE (v 3.9.2)> Warning: not loading native code for module sets: it
>> was compiled for an incompatible runtime system; please regenerate
>> native code for this runtime system
>
>
> Hipe is specific per VM. -smp disable is another VM and the HiPE code does
> not work for it. So if the HiPE code was not generated for non smp VM, this
> is normal, I suppose.
>
>
>>
>> Thoughts?
>>
>> I'll do a rebuild to verify this is not caused by --enable-native-libs
>> as I'm not sure that flag wasn't enabled in this build tree.
>>
> Nope, it's not that, tried it.
>
> What happens if you just do "erl -smp disable" with your newly built erlang
> in the PATH?

Actually, I just tried that before reading the mail and it fails:

$ erl -smp disable
(no error logger present) error: "Error in process <0.3.0> with exit value:
{badarg,[{init,request,1,[]},{erl_prim_loader,prim_init,0,[]},
{erl_prim_loader,start_it,4,[]}]}
"
(no error logger present) error: "Error in process <0.2.0> with exit value:
{badarg,[{erl_prim_loader,request,1,[]},{init,start_prim_loader,6,[]},
{init,do_boot,3,[]}]}
"
{"init terminating in do_boot",{badarg,[{erl_prim_loader,request,1,[]},
{init,start_prim_loader,6,[]},{init,do_boot,3,[]}]}}

Crash dump was written to: erl_crash.dump
init terminating in do_boot ()


More information about the erlang-bugs mailing list