[erlang-bugs] Debugger crashes handling the breakpoints

Ahmed Omar <>
Thu Mar 15 09:29:41 CET 2012


Sorry this is the correct link (based on master not maint)
https://github.com/spawnthink/otp/compare/erlang:master...spawnthink:fix_debugger_breaks_crashes

Note : I found out that the OTP guys has it already fixed in their internal
tests

On Wed, Mar 14, 2012 at 5:38 PM, Ahmed Omar <> wrote:

> This commit should fix your issue
>
> https://github.com/spawnthink/otp/compare/erlang:maint...spawnthink:fix_debugger_breaks_crashes
>
> I already submitted it to erlang-patches
>
>
> On Mon, Feb 6, 2012 at 9:54 PM, Ricardo Catalinas Jiménez <
> > wrote:
>
>> When I add some breakpoints in a module in the source code window, if I
>> close that window and I open it again, all the breakpoints are lost, not
>> shown in the sidebar nor in the `Break' menu.
>>
>> Also, when I open the source code window again (with all the breakpoints
>> lost), if I hit on the menu `Break->Enable All' or `Break->Disable All'
>> the debugger crashes with:
>>
>>        dbg_wx_view:error {badmatch,false}
>>
>> I'm using R15B.
>>
>>
>> Regards
>> --
>> Ricardo (http://r.untroubled.be/)
>> _______________________________________________
>> erlang-bugs mailing list
>> 
>> http://erlang.org/mailman/listinfo/erlang-bugs
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-bugs/attachments/20120315/e6d4bc82/attachment.html>


More information about the erlang-bugs mailing list