[erlang-bugs] dialyzer: {{badmatch,none},[{erl_types,t_limit_k,2},...

Kostis Sagonas <>
Thu Feb 3 12:02:53 CET 2011


Nico Kruber wrote:
> I ran into the following error with the dialyzer, today - maybe you can give me a hint on what is wrong or maybe it is even a bug in the dialyzer(?)

Of course it's a bug of some sort in dialyzer.  The program should not 
crash under any circumstances.  But I/we cannot be of more help without 
more information.  You've really given us nothing here.

Which OTP version is this? What does your PLT contain? How does your 
program look like? ...

What I suggest you do is to check whether you get the same error with 
OTP's 'dev' version from GitHub.  If it is still there, send me, 
preferably off list, a (minimized) test case that shows the problem and 
information on what the PLT should contain in order to be able to 
reproduce and hopefully fix this soon.  If the problem does not appear 
in 'dev', sorry but you are on your own to find out which change fixes this.

Best,
Kostis


More information about the erlang-bugs mailing list