Fix beam/erl_bif_re.c building bug due to wrong version of PCRE is used

Kenji Rikitake <>
Wed Feb 10 14:42:20 CET 2010


git fetch git://github.com/jj1bdx/otp.git r13b03_compile_pcre

Reported by Giacomo Olgeni in the follwing message
http://www.erlang.org/cgi-bin/ezmlm-cgi?3:mss:335:200811:hijljjocpmpkhgkhfkdl
Giacomo also reported this patch is still needed in
the latest build (R13B03) of FreeBSD Erlang port.

Patch summary:

Sorting the $(CC) command line flag so that the local $(INCLUDES)
show up as the first option is required to link with correct PCRE
version.

This patch is mandatory for FreeBSD port build of lang/erlang
(and will not harm the building procedure of other OS)
    
Regards,
Kenji Rikitake



More information about the erlang-bugs mailing list