hipe patch for glibc.i686 2.3.90

Mikael Pettersson <>
Mon Jan 30 19:38:40 CET 2006


Serge Aleynikov writes:
 > We ran into the hipe compilation issue (R10B-9) on Linux Fedora related 
 > to the newer GLIBC version.
 > 
 > $ uname -a
 > Linux stardev1.corp.idt.net 2.6.15-1.1881_FC5.idtsmp #1 SMP PREEMPT Mon 
 > Jan 30 02:16:35 EST 2006 i686 i686 i386 GNU/Linux
 > 
 > Installed Packages
 > glibc.i686   2.3.90-30
...
 > --- erts/emulator/hipe/hipe_x86_signal.c        2006-01-30 10:27:20.000000000 -0500
 > +++ erts/emulator/hipe/hipe_x86_signal.c        2006-01-30 10:15:46.000000000 -0500
 > @@ -27,7 +27,7 @@
 >  #include <stdlib.h>
 >  #include "hipe_signal.h"
 >  
 > -#if __GLIBC__ == 2 && __GLIBC_MINOR__ == 3
 > +#if __GLIBC__ == 2 && __GLIBC_MINOR__ >= 3
 >  /* See comment below for glibc 2.2. */
 >  #ifndef __USE_GNU
 >  #define __USE_GNU              /* to un-hide RTLD_NEXT */

So there will be a glibc-2.4 and FC5 will use it. Thanks for this info,
but note that this patch only fixes up a compilation issue, it doesn't
guarantee that the sigaction override code actually works with glibc-2.4.
That requires testing with a multi-threaded runtime system that is
instructed to create several threads at start-up.

So I would prefer to delay applying this patch until FC5 final is released
(around March 15 it seems) and I've had a chance to test it properly.

/Mikael



More information about the erlang-bugs mailing list