Cannot compile on OpenBSD R9C

Riccardo Mottola <>
Fri Oct 3 20:06:00 CEST 2003


Hello,

I cannot compile R9C-0 on OpenBSD 3.3 for sparc. R9B neither.

I searched the list around and found that the OpenBSD problem comes and goes
from time to time... The package included is till a very old one and is not
enough to run the Wings3D modeler for example.

Is this the correct list where to ask? or better erlang-questions? The
"problem" I have is not SSL but also a VM problem.

Now, I searched archives better... and I found a mail that hitend two
patched.

I modified the memsup.c file and also the Makefile.


now the build completes. I think those patches should be merged in the main
tree and also the OpenBSD manintainers should be thereafter convinced of
upgrading their package! v47 is a bit old.

make install gives a lot of warnings of obsolete stuff, but comes to and end
and "erl" exectues.

Now I build esdl and hope it will work :-)

-Ric




More information about the erlang-bugs mailing list